Introduction

Following an upgrade and migration of Spindle Document Management, users may see the below error message when trying to capture or view documents:


Cause

This issue can occur after a migration and upgrade on a client's server when the old Draycir.SDC SQL database is moved from the previous live server to the new server (or test server) after the installation and upgrade is performed on the new server.

This can also occur if there was a problem migrating the database at the point of upgrading.

The database is an older version than the one expected by the newer version of Spindle Document Management. 

In this case, the Migrate Data button does not become in Server Administration as the software believes that it has already upgraded the database to match the new version.


Sometimes this can be confirmed by checking the most recent Errors.log in the Spindle Document Capture server log folder (C:\ProgramData\Draycir\Spindle Document Capture\Server\Logs).

If the database is a lower version, the below error may appear in the log:

Inner Exception


        ---------------


        Type : System.Data.SqlClient.SqlException, System.Data, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089


        Message : Invalid object name 'dbo.DataSetPermissions'.


This references the table dbo.DataSetPermissions which is present in newer versions of the Draycir.SDC database. When this error appears, it means that it cannot find the table when checking the database.


Solution

We must force Spindle Document Management to re-migrate the database to bring it up to the current version.


On the application server, navigate to C:\ProgramData\Draycir\Spindle Document Capture\Server\Data and take a backup copy of the file Configuration.xml (to revert in case of any issues).

Open the file in a text editor (such as Notepad) and change the number in the <RootSchemaVersion> section to a value lower than the original.

In the below example, the value has been set to a lower version number:

Save the file, then restart the Spindle Document Capture and Spindle Document Capture Mobile services, and re-open Server Administration. The Migrate Data button should now be accessible:

Click Migrate Data and allow it to upgrade the database.


Related ProductSpindle Document Management
Ref NumberKBA-05-03-023
Document Date08/02/2023
Original AuthorMatthew Perry
Document Versionv1.0
Last updated 08/02/2023
Update Author Matthew Perry