Introduction
Following an upgrade and migration of Spindle Document Management, the below message may appear when opening Spindle Document Distribution Tools:
Causes
Database Update Required
Following an upgrade, the version of the Spindle Document Distribution database will need to be upgraded. This can occur when running the Spindle Document Management Server if the folder path is properly specified, or performed manually after installation.
SpindlePro Folder Mismatch
During a migration and upgrade, the correct path to the SpindlePro shared folder may be skipped when running the installer for Spindle Document Management Server. This can lead to the client side receiving the message prompting to update the database, but running the Database Update application will show that it does not need to be upgraded.
Solution
Database Update Required
This can be performed by running the executable named Database Update.exe, located in in C:\Program Files (x68)\Draycir\Spindle Document Management\Spindle Document Distribution Server\
SpindlePro Folder Mismatch
On the app server, Open the file Configuration.xml in C:\ProgramData\Draycir\Spindle Document Distribution\Server\Data and check if the <DataPath> section is looking at the correct file path (Such as C:\Sage\Logon if that is the path to the SpindlePro folder). If not, amend this section and save Configuration.xml and restart the Spindle Document Capture Services.
Afterward, run the update wizard again and this should allow it to update.
Related Product | Spindle Document Management |
Ref Number | KBA-05-03-025 |
Document Date | 25/06/2024 |
Original Author | Matthew Perry |
Document Version | v1.0 |
Last Updated | 25/06/2024 |
Update Author | Matthew Perry |