Introduction
When attempting to open the Server Administration application, the below error message may appear:
Causes
This error is caused by one of the files located in the Spindle Document Capture server data path becoming corrupted.
Solution
Open File Explorer and navigate to C:\ProgramData\Draycir\Spindle Document Capture\Server\Data
In this folder, check the file size of the .xml files - an affected file would be 0KB in size, or empty when opened.
Below is a screenshot of an example where the file Configuration.xml is affected:
In this case, we can see that the file is 0KB in size.
To resolve the issue, delete the file and perform a repair install of Spindle Document Management Server. The repair install can either be done from the Control Panel (in appwiz.cpl), or by running the installer for Spindle Document Management Server.
If the user running the Windows services and IIS application pools relating to Spindle Document Capture is not the default local user (SERVERNAME\SDCServiceUser), then the credentials for the user will need to be re-applied to the below after the repair:
Windows Services:
Spindle Document Capture (DMServiceHost)
Spindle Document Capture Mobile (DMMobileServiceHost)
IIS Application Pools:
SDCAdmin
SDCWebApi
After the repair install has been performed, a new copy of the file should be visible in the Data folder. Depending on the affected file, some part of the configuration would need to be restored.
For example, if Configuration.xml is affected - The licence will need to be re-applied. If the activation details are required again, please request them from licences@draycir.com
Related Product | Spindle Document Management |
Ref Number | KBA-05-03-028 |
Document Date | 11/06/2025 |
Original Author | Matthew Perry |
Document Version | v1.0 |
Last Updated | |
Update Author |
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